[sane-devel] usb_control/bulk_msg: timeout

Bill Moseley moseley@hank.org
Thu, 2 Jan 2003 13:53:06 -0800 (PST)

On Thu, 2 Jan 2003, Henning Meier-Geinitz wrote:

> Do you have any other USb devices? Or maybe you have different USb
> root hubs?

Nope, the scanner is the only device.  I've tried both ports on the back
of this machine.

> I would first check that it's really the scanner, e.g. by
> using a different operating system and trying at a different computer.
> Maybe it's the mainboard and then you have the same problem with the
> next scanner...

Ok, I can try another computer, I guess.  I tried Knoppix CD just now and
I got the same I/O errors.  I'd rather buy a new scanner than install
Windows on my desktop machine ;)  I have used this scanner on Windows in
the past, without problem -- but just not on this machine.  It's a MSI
K7T266 Pro2 motherboard.  Maybe I could throw in a new hard disk and
install Windows.

It would be too bad if it's a motherboard.  Seems unlikely, though.

If I were able to test the the hardware and find out it's ok, then where
should I focus my debugging?  

Is the usb_control/bulk_msg: timeout message generated in the scanner
module?  And is that what is causing the front-end X apps to report the
"I/O" error?  I wonder if I could get the scanner module to tell more
about what's timing out.

I assume the scanner module talks to the usb module to get out to the

It seems odd to me that one X frontend works yet the other fails with an
I/O error.  I don't know the Sane API but I assumed that the all apps
would see the same problem using the same API.

A lot of work to just scan a few images of the kids!

Thanks for your time.  I'll post again if I can figure anything out.

Bill Moseley moseley@hank.org