[sane-devel] epson 1250u vs 45-TEST5

Gene Heskett gene_heskett@iolinc.net
Sun, 5 Jan 2003 15:05:21 -0500

On Sunday 05 January 2003 14:48, Gene Heskett wrote:
>Hi everybody;
>I just rebuilt the sane-backends-1.0.9 with the plustek-45-TEST5
>patches, something I hadn't done in several versions now.
>On deleting config.cache and config.status & re-running
> ./configure, configure made me aware that there was sane stuff in
> /usr, but that the instant install was going to be /usr/local. 
> So I went thru /usr/bin and /usr/lib, getting rid of anything
> that looked as if it was sane related.  Then I redid the whole
> confiyre thing from scratch, made it and installed it.
>On launching xsane from desktop icon, I was pleasantly surprised
> to see it list my hauppage wintv (bt 848) card as a source driver
> option, but didn't try it.  And I didn't try the epson backend
> either, but selected the plustek for this test.  During this
> scanning for devices phase, it did turn on the lamp for about 100
> milliseconds.
>Selecting the plutek backend I clicked ok and all the windows
>associated with the plustek backend opened up normally.
>As there was something already on the glass, I hit the acquire
>preview button.  It turned on the lamp, waited about 1:30, then
>moved it forward about 1 mm, then back about 2mm and shut it off
>for half a second somewhere in the middle of that sequence.  Then
>it started the preview scan at a fairly rapid scan rate, and very
>very quietly, a major improvement.
>When it reached the end of the forward scan, it cleared the
> preview screen for about 1/2 second, and then the whole thing
> went instantly away, leaveing the scanner in the rewind mode,
> which it did very quietly, stopping when it reached the home
> position long after everything from xsane was cleared from the
> screen leaving me watching the wallpaper.
>Trying out the bt848 option, it captured a blank, 18% grey screen.
>(theres no antenna feed to the card at the moment so it should
> have been snow, but what do I know, I'm just a broadcast tv
> engineer).
>Then trying the epson gt-7200 (or was the 6800?) it still worked
> at least in preview mode.
>I tried to run xsane from the shell and had to go delete even more
>of the older xsane-0.84 install, sigh & damn redhats
>install/upgrade scripts, I done that twice already.
>However, just for grins & in case its fussy, I'll go make xsane
> and sane-front-ends-1.0.9 fresh again now that this version of
> the backends is in place.
>My /var/log/messages file is growing with lots of messages that
>read:Jan  5 14:37:24 coyote kernel: scanner.c: open_scanner(1):
>Unable to access minor data
>Jan  5 14:37:23 coyote kernel: scanner.c: open_scanner(15): Unable
>to access minor data
>Jan  5 14:37:24 coyote kernel: Device not ready.  Make sure there
> is a disc in the drive.
>Jan  5 14:37:24 coyote kernel: VFS: busy inodes on changed media.
>Jan  5 14:37:24 coyote kernel: sda : READ CAPACITY failed.
>Jan  5 14:37:24 coyote kernel: sda : status = 1, message = 00,
> host = 0, driver = 08
>Jan  5 14:37:24 coyote kernel: Info fld=0xa00 (nonstd), Current
>sd00:00: sns = 70  2
>Jan  5 14:37:24 coyote kernel: Raw sense data:0x70 0x00 0x02 0x00
>0x00 0x0a 0x00 0x00
>Jan  5 14:37:24 coyote kernel: sda : block size assumed to be 512
>bytes, disk size 1GB.
>Jan  5 14:37:24 coyote kernel:  sda: I/O error: dev 08:00, sector
> 0 Jan  5 14:37:24 coyote kernel:  I/O error: dev 08:00, sector 0
> Jan  5 14:37:24 coyote kernel:  unable to read partition table
> Jan  5 14:37:24 coyote kernel: scanner.c: open_scanner(1): Unable
> to access minor data
>And any attempt to scan for real dies in about 3" of forward
> motion at 300 dpi, plus the motor complains a wee bit as its
> getting started, like its hitting the backstop maybe.  It doesn't
> do this in preview mode.
>Also, in the FWIW category, the histograms do not display Olivers
>logo when in the epson gt-7200 driver mode.
>So whats next kind folks?  What did *I* screw up this time?

Ok, I'll bite.  I closed out this message and sent it, then figured 
I'd run xsane from a shell to see what errors it might report as it 

Yeah, sure.  Yup.  Its working now!  Humm, pulldown all the gamma 
sliders with the left hand button so its running exactly as before, 
and do it again...  Still works.  Silly Q? The only other thing I'd 
done was to delete ~/.sane/xsane as it recommended, and I just 
resaved it, but hadn't before.  Is that (the missing 
/home/.sane/xsane stuff) enough to make it puke?

Anyway, I'l go quietly now.  I watched carefully as it went thru the 
cal motions before doing the scan, and the motor complaints come as 
its stepping forward that first 2 mills, then it backs up quietly 
and does the scan just as quietly.  I'm going to go check for that 
line artifact now, so I may be back to report on that.

Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz  512M
99.21% setiathome rank, not too shabby for a WV hillbilly