[sane-devel] Epson 1250u vs plustek-45-TEST5

Gene Heskett gene_heskett@iolinc.net
Mon, 6 Jan 2003 14:37:55 -0500

On Monday 06 January 2003 13:47, Jaeger, Gerhard wrote:
>Hi Gene,
>On Sunday, 5. January 2003 21:39, Gene Heskett wrote:
>> Hi all;
>> The artifact is still there, but I have a more pressing problem,
>> I've forgotten the location of the focus variable, at 600 dpi,
>> I'm seriously out of registration.
>> Humm, might have found it, the comment says "sensor distance" &
>> 16 is way too high for my scanner, so I'm rebuilding it at 8. 
>> Is that the right setting for your's Reinhart?  In which case we
>> have a pretty serious production tolerances problem with this
>> beast...
>hmpf, that was my fault. In the meantime fixed - 8 is the correct
> value.
>> Humm, finished the scan at 600 dpi ok, small piece of the
>> original, then segfaulted without showing it to me.  And thats
>> all it says in the shell when it returned.  But I didn't acquire
>> a preview first, just sent it to do that same scan again. 
>> Restart, do preview, get segfault at end of forward scan.  I
>> sure wish this thing would make up it mind.  Restart from icon,
>> save prefs (again) first, preview works.  Restore teeny size &
>> do 600 dpi.  Worked, and the registration is now spot on.  White
>> line artifact still there.
>It is not present here nay longer on my 1260, even the TPA
>stuff works now. But the code is not available currently...

Post a notice here when it is please :-)

>> I don't think this is quite "Ready for prime time" :-(  We still
>> have that white vertical line artifact, and the segfault at the
>> end of the scan seems to be somewhat of a coin toss.  Phase of
>> the moon, odd/even minute, whatever.
>- phase of the moon! I didn't get any segfaults here after a scan.

Now wait a minute, I don't want any MORE poltergeists in my system!  
With kwin crashing if I'm playing a game and actually win, I don't 
need any more ghosts.  I've also downloaded the latest bugzilla, 
and installed 20 megs worth of stuff from CPAN that it says it 
needs, but I still can't file a bugreport against kwin and there 
does not appear to be any humans at bugs.kde.org to override 

Thats O.T. here, so back to sane/plustek:

Whats the appropriate debugging line I should use to turn it on & 
see if it can be trapped/pinpointed?

>> Suggestion/feature request:  Can this thing get a focus
>> adjustment made available in the gui, and saved in the prefs? 
>> We no doubt have some users who aren't quite comfortable
>> shuffling around in the source code with vi just to get the
>> proper focus/registration for their individual scanner, and
>> obviously from this, hard coding it isn't going to be optimum
>> for everybody.  Mine was pretty bad when set for 16, but I
>> remembered 8 was pretty good from previous testing, and it still
>> is.
>No need to have this adjustment, as it should be okay for all

How did it get reset to 16 then?  Possibly for the TPA maybe?  But 
that seems counterintuitive to me, or do positive numbers raise the 
scanhead, in which case getting into focus for a mounted slide, 
that setting may be correct.  Somehow I had it fixed in my mind 
that greater numbers meant farther from the glass, not closer.

In any event, the TPA is surely going to need a different setting if 
for no other reason than the thickness of the slide mount frame 
raising the film off the glass at least far enough to get rid of 
the newtons rings.  Also in that event, the array isn't capable of 
holding a seperate value for each mode.  Fixing that will be a 
major hack too.  :(  Which is half the reason I asked for the prefs 
setting instead, which is probably about the same amount of coding 
& caffiene in the long run.

Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz  512M
99.21% setiathome rank, not too shabby for a WV hillbilly