[Fwd: [sane-devel] saned/Epson problems - ?third try?]

Lars Tšuber taeuber@informatik.hu-berlin.de
Tue, 07 Jan 2003 21:39:49 +0100


first i want to correct a mistake of mine in the first posting on this
list: i didn't write khk about this problem but oliver rauch from xsane,
i'm sorry but i looked to all possibilities that could be responsible
for my problem and mixed up khk and oliver

please don't mind


> > there is another client in the intranet that has not the problems but it
> > is an older xsane (0.77 i think) and an older sane version (1.0.7 i
> > think), but i'll have a lock again
> >
> > (xsane 0.77 -> net client 1.0.7 -> saned server 1.0.9 works) (10mbit
> > switched)


sorry it is xsane 0.80 working on this client with sane 1.0.7

> 
> That's interesting. There is only one change in the net backend
> between 1.0.7 and 1.0.9 that may cause problems with options. Well, at
> least theoretically. The new code looks correct for me.
> 
> Can you test xsane 0.90 with net client 1.0.7 or vice versa? So we
> could find out if the difference is xsane or the net client.

            xsane 0.80  xsane 0.90
sane 1.0.7  works       does not work (see below)
sane 1.0.9  works       does not work


the test-backend works in either case (with net:host:test 1.0.9 and
xsane 0.90)

debug output on the server  (netgate)

client with 1.0.7:
Jan  7 19:13:04 netgate saned[10507]: check_host: access by remote host:
192.168.1.3 
Jan  7 19:13:04 netgate saned[10507]: init: access by
saned-user@192.168.1.3 accepted 
Jan  7 19:13:20 netgate saned[10507]: quit: exiting 
client with 1.0.9:
Jan  7 19:17:18 netgate saned[10520]: check_host: access by remote host:
192.168.1.2 
Jan  7 19:17:18 netgate saned[10520]: init: access by elte@192.168.1.2
accepted 
Jan  7 19:19:42 netgate saned[10520]: quit: exiting 

i installed xsane 0.80 on the client with sane 1.0.9 and it worked then
i installed xsane 0.90 again and it worked too.
after quitting and restarting xsane it didn't work again!
only deleting ~/.sane/xsane has not the effect like installing and
running xsane 0.80 before xsane 0.90.
so i played a bit with the settings under xsane. xsane 0.90 works under
special circumstances:

when you change the 'drop out' in 'binary' mode you can switch to
'color' afterwards
when you change the 'bit depth' in 'color' mode (when you are in color
mode at startup) you can change other settings too.
that is a bit confusing to me, because i see no reason for this
behaviour.
by the way is it a sane limitation or a sane-driver limitation that i
can't scan with 4800 dpi resolution, 
because the scanner is able to do a scan with 2400x4800 dpi physically?


the scanner locally connected to the client using xsane 0.90 works as
expected

i hope this reports is helpful in any way


-- 
Regards
Lars

*******************************************************************
*  Lars Tšuber                             *     Es lebe GNU!     *
*  Berlin, Germany                         *  God save the GNU!   *
*  mailto:taeuber@informatik.hu-berlin.de  *  http://www.gnu.org  *