[sane-devel] UMAX Astra 2200 USB weirdness (Repost)

Matthew matthew@mattshouse.com
Mon, 28 Jul 2003 13:16:05 -0500

This is an extension of the thread from 17 Jun 2003 regarding the 
problems with the UMAX Astra 2200 series scanner connected via USB.   
This is a repost due to my inability to send from the correct e-mail 
address. :-)


I'm having the same problem, as described below:

 From xsane I can "Preview" an image, but when I try to "Scan" an image 
the interface locks up and I start to see the following in the syslog:

Jul 28 10:39:45 scan4 kernel: usb_control/bulk_msg: timeout
Jul 28 10:40:25 scan4 last message repeated 2 times
Jul 28 10:41:25 scan4 last message repeated 3 times

Followed later by:

Jul 28 10:48:43 scan4 kernel: scanner.c: read_scanner(0): excessive 
NAK's received

I then have to unload usb-ohci.o and scanner.o before trying again. 
incidently, xscanimage locks up immediately.

I've tried several combinations of kernel/sane.

Redhat kernel 2.4.20
Stock Linus kernel 2.4.21
Stock Linus 2.4.21 + 2.4.22-pre6

Stock Redhat sane 1.0.9-5
Rawhide sane 1.0.12-4
sane cvs snapshot from Jul 27th (after thouroughly removing the prev vers).

All of the combos above yield the same result.

The scanner that I'm using is described as such from `lsusb`:
idVendor           0x1606 Umax [hex]
idProduct          0x0230 Astra 2200/2200SU

Like I said, the "Preview" works but the "Scan" does not.  It doesn't 
matter whether or not I've already done a "Preview".

If you need further information, or need access to the machine just let 
me know.  In any case it seems that others are having the same problem 
so the Supported Scanner matrix should probably be updated to show 
something other than "stable" since I used that to guide my purchase.

Let me know if I can be of further assistance.