[sane-devel] ScanJet 3400c

Bertrik Sikken bertrik@zonnet.nl
Sat, 15 Nov 2003 20:21:24 +0100

Kernel wrote:

> Hi Bertrik,
> 	I tried everithing you told me to but nothing worked.
> Usbdevfs is mounted on /proc/bus/usb and I loaded scanner kernel modul, but 
> nothing. It still sayes "scanimage: open of device niash:libusb:001:002 
> failed: Device busy". The interesting thing is that I uncommented the 
> "/dev/usbscanner" in /etc/sane.d/niash.conf and scanimage tells me that 
> scanner is on libusb. Is this normal?

If you have the scanner kernel module loaded (scanner), then
there should be a file like /dev/usbscanner0, /dev/scanner0 or
/dev/usb/scanner0 and scanimage should be able to open it
without further configuration. Perhaps there is something weird with
the Suse scanner kernel module.

Do you see any message in /var/log/messages or dmesg when plugging
in the scanner or when loading the scanner kernel module?

Perhaps your libusb is a very old version. There was an issue with
a very old version of libusb (i think it was 0.1.3).

The device name in niash.conf currently does not have any effect.