[sane-devel] Mandrake 9.1 and ServeRAID 5i

Raf Schietekat Raf_Schietekat@ieee.org
Wed, 17 Sep 2003 16:16:58 +0200

abel deuring wrote:

> So it seems that neither the RAID controller nor its Linux driver nor
> sane-find-scanner is buggy.

It's ridiculous. Maybe I should become a psychiatrist, because people 
are more predictable. I've now done "perl -d `which scannerdrake`", and 
no failure occurred. Then I tried without -d. Then I tried harddrake2, 
and drakconf, several times. No failure. The only strange thing that 
remains is that, across reboots (I'm just trying anything at this 
stage), the list of Scanner devices in harddrake2 (part of drakconf) is 
either the 4 mentioned before, or just the two called SERVERAID, which 
does seem rather suspicious, but probably no immediate cause for alarm. 
Yet, before the reinstallation (could that be it?), one failure occurred 
right after using harddrake2, one was seemingly provoked by 
scannerdrake, and then there's also the bug report I found.

Let's look one last time. drakconf>Hardware>Hardware List. A window 
"Please wait/Detection in progress" appears. It seems to take a *very* 
long time. I go check the server. Two of three drives have their 
"defunct" indicator LEDs lit...

But that's enough for today. Next thing is probably installation of Red 
Hat, or Turbo Linux, or SuSE, because IBM won't support Mandrake. If I 
find out anything else that's relevant here, I'll report it. Meanwhile, 
thanks for your efforts to help.

Raf Schietekat <Raf_Schietekat@ieee.org>