[sane-devel] Mandrake 9.1 and ServeRAID 5i

abel deuring adeuring at gmx.net
Wed Sep 17 19:20:12 BST 2003

Raf Schietekat schrieb:
> abel deuring wrote:
>> [...]
>> So it seems that neither the RAID controller nor its Linux driver nor
>> sane-find-scanner is buggy.
>> [...]
> It's ridiculous. Maybe I should become a psychiatrist, because people 
> are more predictable.


> I've now done "perl -d `which scannerdrake`", and 
> no failure occurred. Then I tried without -d. Then I tried harddrake2, 
> and drakconf, several times. No failure. The only strange thing that 
> remains is that, across reboots (I'm just trying anything at this 
> stage), the list of Scanner devices in harddrake2 (part of drakconf) is 
> either the 4 mentioned before, or just the two called SERVERAID, which 
> does seem rather suspicious, but probably no immediate cause for alarm. 
> Yet, before the reinstallation (could that be it?), one failure occurred 
> right after using harddrake2, one was seemingly provoked by 
> scannerdrake, and then there's also the bug report I found.
> Let's look one last time. drakconf>Hardware>Hardware List. A window 
> "Please wait/Detection in progress" appears. It seems to take a *very* 
> long time. I go check the server. Two of three drives have their 
> "defunct" indicator LEDs lit...
> But that's enough for today. Next thing is probably installation of Red 
> Hat, or Turbo Linux, or SuSE, because IBM won't support Mandrake.

Yes, tracing the bug could take quite some time, and I presume that you 
need to get your server installed and running. While I would really like 
to know, why and how the RAID array is messed up, this job must probably 
be left to Mandrake and/or IBM -- most people don't have a RAID 
controller and SCSI disks lying around in a junk box.


More information about the sane-devel mailing list