[sane-devel] Scanner recognized and scans completed <'Ray!>

Barton Bosch barton_bosch at eudoramail.com
Sat Sep 27 06:55:14 BST 2003

I worked on the scanner snafu for a good while today and following your suggestions I managed to solve the problem and get the scanner up and running.  <'Ray!>

As it turns out Linux is not initializing my scsi setup correctly in that it does not load the sg module or the fdomain module for my host adapter.  I tried lsmod and modprobe sg, per Abel's tip and found that sg wasn't loaded.  I tried xsane and sane-find-scanner after loading sg as su root but it still didn't find my scanner.  

For some odd reason it occured to me to try "modprobe sg" while logged in to the real root account, and after this checked out lsmod and found that this time the fdomain module was loaded.  Sure enough, this was the sticking point.  

Manually loading the sg and fdomain modules allows xsane and sane-find-scanner to see my scanner, and I managed to make a couple of basic scans of some documents that I have needed to fax for the last few days.  Even managed to use linux to fax them as well. 

I think that when I did my previous install of a different flavor of Red Hat I had my SCSI host adapter in the computer from the start, whereas this time I installed the host adapter a couple of months after this Linux install.  

So now my question is, what do I need to do to get the sg and fdomain modules to load at boot?  Just a modification to /etc/modules.conf?  If so, does anyone know what the exact syntax would be?  Or can you point me toward the relevant documentation?

Oh, and FWIW, I did try disabling the ide-scsi module before and after I tried modprobe sg while logged in as root, and it is not necessary with RH 8.0 and the 2.4.18-14 kernel.

Vielen dank and shalom aleichem.


Need a new email address that people can remember
Check out the new EudoraMail at

More information about the sane-devel mailing list