[sane-devel] Epson Perfection 1640SU with ADF or Filmadapter

Terje J. Hanssen nteknikk@monet.no
Mon, 23 Aug 2004 02:10:57 +0200

Henning Meier-Geinitz wrote:

> On Wed, Aug 18, 2004 at 06:21:15PM +0200, Terje J. Hanssen wrote:
>>> I would just add that I am also able to run "xscanimage" after the sane
>>> installation. But as far as have seen, the xscanimage is set up for
>>> flatbed scanning only and with no selection for ADF.
> Generally speaking xscanimage can also use an ADF as usually the
> selection to use an ADF is a ANE option or is a fixed setting.
> However, you are right as xscanimage only scans one page when you
> press the scan button.
> Besides xsane, scanimage and scanadf provide support for doing batch
> scans.
I have tested more and extracted output as follows and added some questions:

1) Hardware info:

/usr/sbin/hwinfo  (extract of "EPSON" related content of a logfile) :
   Vendor: EPSON    Model: Perfection1640   Rev: 1.03
   vendor "EPSON", model "Perfection1640", rev "1.03", type "Processor"
   vendor "EPSON", model "Perfection1640", rev "1.03", type "Processor"
   Model=EPSON Perfection1640
   Model=EPSON Perfection1640
 Model: "EPSON Perfection1640"
 Vendor:  "EPSON"
 Model: "EPSON Perfection1640"
 Vendor:  "EPSON"

2) epson.conf:

My /etc/sane.d/epson.conf file contains only one line that is not 
commented out: scsi epson

3) scanimage:

# scanimage -L
device `epson:/dev/sg0' is a Epson Perfection1640 flatbed scanner

# scanimage -d epson:/dev/sg0
run flatbed scanning

scanimage -h shows all options available. There is listed an option
"--source flatbed|Automatic Document Feeder"
I tried something like

# scanimage -d epson:/dev/sg0  --source Automatic Document Feeder
This syntax was obviously not correct. Can someone tell me how it should
looks like to scan from the ADF?

3) xscanimage:

# xscanimage -ANE
didn't work. Is this the correct syntax to scan from the ADF?

However I discovered that starting xscanimage (without options) and by 
enlarging the X widget, a selection for scan source (like that in xsane) 
became visible. I selected Automatic Document Feeder and clicked on the 
Scan button. An error message said: Fail to start scanner, error during 
device I/O. That is exact the same message as mentioned with xsane. No 
scanning at all started. Only setting the source back to the default 
Flatbed worked and scanned from the flatbed again.

4) scanadf:

# scanadf
started scanning from the flatbed! (not from the ADF): image-001, 
image-002 and more and looked to never stop this process. I quitted the 
program with Ctrl-C in the terminal window, and the scanner stopped 
(pause).  From another terminal window I verified that scanimage -L not 
longer could identify any scanner. I quitted the first terminal window, 
and now the scanning process continued, until I rebooted the system.
Is this correct? Shouldn't scanadf start scanning from the ADF only?

Terje J. Hanssen