[sane-devel] sanei_usb and libusb_timeout
Wed, 1 Dec 2004 21:45:30 +0100
On Wed, Dec 01, 2004 at 02:39:54PM -0500, m. allan noah wrote:
> is there any value to makeing this function call have a more generic name,
> like sanei_set_timeout() which could perhaps be a noop in the scsi case
> for now? is variable timeout ever going to apply to scsi?
It could be of some use for SCSI, too. However, I don't think the same
function should be used for both. One, it may make sense to use
different timeouts for USB and SCSI (in backends supporting both
busses). Two, I have no clue how to easily implement the same function
call for sanei_scsi and sanei_usb without getting trouble when both
objects are linked to a lib.