[sane-devel] Problem with Epson Perfection 2480 Photo

Jean-Christophe VIALLET j.viallet@free.fr
Sun, 05 Dec 2004 15:24:07 +0100


I've been searching a lot on the net but I did not find how to make it work.

I'm using libsane1-1.0.14, sane-backends-1.0.14, xsane-0.93 from a 
Mandrake box with a 2.4.22 kernel.

The scanner is recognized using sane-find-scanner :

   # No SCSI scanners found. If you expected something different, make 
sure that
   # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x0121 [EPSON 
Scanner]) at libusb:002:013
   # Your USB scanner was (probably) detected. It may or may not be 
supported by
   # SANE. Try scanimage -L and read the backend's manpage.

   # Not checking for parallel port scanners.

   # Most Scanners connected to the parallel port or other proprietary ports
   # can't be detected by this program.

But xsane reports it detects no devices.

The command cat /proc/bus/usb/devices gives :

T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 11 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=04b8 ProdID=0121 Rev= 1.10
S:  Manufacturer=EPSON
S:  Product=EPSON Scanner
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=16ms

I find very strange that Driver is (none) !

I even tried to load the scanner module with modprobe but it doesn't 
work better.

I've tried several configurations with files snapscan.conf but without 
any success.

Any idea ?

Thanks by advance