[sane-devel] epson 2400 photo: scanimage -L error

r k roland19955@yahoo.com
Wed, 29 Dec 2004 07:11:40 -0800 (PST)


My problem is that sane-find-scanner finds my scanner,

but scanimage -L doesn't.
I also don't get a clue where to look for solving this
problem.
I already read all kinds of manpages and
documentation,
and googled for hours on this problem.

Curious is that with linux 2.4.28 and module scanner
everything works
just fine. But it is impractical to run mostly linux
2.6 and only for scanning
linux 2.4.

A bad sign is that with the knoppix cd the scanner
also only works 
on linux 2.4, not linux 2.6, which is called
'experimental' there.

Other usb devices work normally, e.g., the usb memory
stick within a digital
still camera.

I tried to read some sane source code, but it seems
impossible to find out
how and where scanimage tries to open devices. Sane
doesn't look that simple.
Curious is that I couldn't get any debug output from
scanimage,
as shown below.

I would be very greatful for any hints on this
problem.

Greetings, Roland

NB: here are some details of my setup.

Linux 2.6.9
Debian sarge
sane 1.0.13, libsane/libsane-dev/sane-utils 1.0.15
usb 1 without ehci_hcd, with module uhci_hcd, usbcore

export SANE_DEBUG_DLL=255
export SANE_DEBUG_EPSON=255
export SANE_DEBUG_SANEI_USB=10
sane-find-scanner
-->
stdout: found USB scanner (vendor=0x04b8,
product=0x011b) at libusb:002:002
stderr:
[sanei_usb] sanei_usb_init: couldn't open
/dev/usbscanner: No such device
[sanei_usb] sanei_usb_init: couldn't open
/dev/usb/scanner0: No such device
...
[sanei_usb] sanei_usb_init: couldn't open
/dev/usb/scanner15: No such device
...
[sanei_usb] sanei_usb_init: found libusb device
(0x04b8/0x011b) interface 0  at libusb:002:002
[sanei_usb] sanei_usb_init: found 1 devices
[sanei_usb] sanei_usb_open: trying to open device
`/dev/usb/scanner'
[sanei_usb] sanei_usb_open: can't find device
`/dev/usb/scanner' in list
  idem for /dev/usb/scanner0..15
USB error: error sending control message: Operation
not permitted
 (this error was printed 8 times)

scanimage -L
--> No scanners were identified.
 (no debug output)



		
__________________________________ 
Do you Yahoo!? 
All your favorites on one personal page  Try My Yahoo!
http://my.yahoo.com