[sane-devel] Canon CanoScan FB630U scanner, 2.6.x kernel and libusb problem

Michele Dall'Arno michele.dallarno@tin.it
Tue, 28 Dec 2004 18:32:17 +0100

After googling a lot and working a bit, I understood that Canon CanoScan 
FB630U scanner does't work with 2.6.x kernel and libusb, but it works 
perfectly with 2.4.x kernel and scanner module. I'm using the last 
release of libsane (1.0.15) and sane (1.0.13).

That's what I did (unsuccessfully) to try to make the scanner working 
properly under 2.6.8 kernel with libusb.
In file /etc/sane.d/dll.conf I commented out all rows except:


In file /etc/sane.d/canon630u.conf I commented out all rows except:

    usb 0x04a9 0x2204

In file /etc/fstab I added the row:

    none            /proc/bus/usb    usbfs            defaults        
0        0

That's the output of sane-find-scanner (that's good):

    found USB scanner (vendor=0x04a9, product=0x2204 [CanoScan FB630U]) 
at libusb:001:003

That's the output of scanimage -L (sounds good too):

    device `canon630u:libusb:001:003' is a CANON Canoscan FB630U flatbed 

That's the output of scanimage >image.pnm (here is the problem):

    scanimage: sane_start: Device busy

and nothing is scanned.

With 2.4.27 kernel and scanner module it works fine:

    $ sane-find-scanner
    found USB scanner (vendor=0x04a9, product=0x2204) at /dev/usb/scanner0

    $ scanimage -L
    device `canon630u:/dev/usb/scanner0' is a CANON Canoscan FB630U 
flatbed scanner

    $ scanimage >image.pnm

and the image is perfectly scanned!

I tried these on my Debian Sarge, but I found the same problem on my 
SuSE 9.2  and read of many users with the same problem on many other 
I googled a lot, and found a lot of people with the same problem, and no 
one could find a solution. All the solutions I found (remove the 
/tmp/canon.cal file and so on) refear to different problems.
I don't know if this a libusb bug, a sane bug or a canon630u backend 
bug. If you think there is a better place to post this bug, please let 
me know.
I tried to be more simple and exaustive that I could, you can contact me 
at michele.dallarno@tin.it in English or Italian for more explanations. 
I apologize for my bad English, I'm Italian.

Can anyone show me/us a solution? Does libusb/sane/canon630u backend 
needs a bugfix? Did you install correctly your Canon CanoScan FB630U 
scanner on 2.6.x kernel and libusb?