[sane-devel] problems with microtek X6 scanner in TMA mode

Karsten Festag karsten.festag@gmx.de
Sat, 3 Jan 2004 21:52:24 +0100

Hi Joachim,

I hope I found the bug. It is in the function 'attach'. There are several 
calls like

status = scsi_read_attributes(&md->info[MD_SOURCE_ADF], md->name, 

They all must have the first parameter  &md->info[0] so that they look like:

status = scsi_read_attributes(&md->info[0], md->name, MD_SOURCE_ADF);

Are you able to check if this is the solution to the problem by recompiling 
SANE with this modification? (The best thing is to use the source rpm provided 
by SUSE and modify them.)


On Sunday 21 December 2003 20:00, you wrote:
> Am Samstag, 20. Dezember 2003 17:23 schrieben Sie:
> > Hi Joachim,
> >
> > thanks for the logfiles, it looks like the backend uses the wrong
> > values, I'll have to check this.
> >
> > Do you remember which SANE version the TMA used to work with
> > before?
> Hi Karsten,
> I'm not 100% shure, but I think that it worked up to at least SuSE
> 7.3.
> I'n the beginning (around 1998/99) there were some problems with the
> microtek firmware (at least V 1.6 was required) but then everything
> worked o.k.
> Yours