[sane-devel] Cannot set up an EPSON Perfection 2400 PHOTO

Lincoln Peters sampln@sbcglobal.net
Thu, 08 Jan 2004 21:43:24 -0800

I had heard that my EPSON Perfection 2400 scanner was supported by
SANE.  I plugged it into the USB port on a computer running Red Hat
Linux 9.0, installed SANE from source, and then ran the
"sane-find-scanner" program.  I got the following output:

# sane-find-scanner
  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating system.
  # If using Linux, try "modprobe sg".
found USB scanner (vendor=0x04b8, product=0x011b) at /dev/usb/scanner0
found USB scanner (vendor=0x04b8 [EPSON], product=0x011b [EPSON Scanner]) at libusb:001:002
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
  # Scanners connected to the parallel port or other proprietary ports can't be
  # detected by this program.

As the "sane-find-scanner" program suggested, I ran "scanimage -L", and
got the following:

# scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

As the HOWTO suggested, I tried it again:

# scanimage -L
device `epson:/dev/usb/scanner0' is a Epson GT-9300 flatbed scanner

I know that my scanner is NOT an Epson GT-9300!  I seem to be able to
scan pictures even when the scanner is incorrectly identified, but they
come out as line art (perhaps this is because I haven't yet looked up
the EPSON-specific command line options).

I have commented out every driver listed in /etc/sane.d/dll.conf
*except* the "epson" driver, to minimize the chance of SANE using the
wrong driver.  Furthermore, the /etc/sane.d/epson.conf file has every
line commented out except for:

usb /dev/usb/scanner0

I also double-checked that libusb is installed.  I don't have any other
USB devices connected to the computer, but I am reasonably sure that the
USB interface itself is properly configured (I wouldn't expect a
misconfigured USB interface to be able to report that I have an EPSON
scanner).  I am also sure that the problem does not lie in the
permissions (I'm using it while logged in as root).

I have also found that, for some reason, if I leave it and come back a
few minutes later, SANE will fail to find my scanner.  The
"sane-find-scanner" command works as before, but "scanimage -L" fails to
detect a scanner no matter how many times I try it.  If I try to scan
the image using the command:

# scanimage -d epson:/dev/usb/scanner0 --format tiff > new.tiff

I get the following error:

scanimage: open of device /dev/usb/scanner0 failed: Invalid argument

According to both the website and the mailing list archives, the EPSON
Perfection 2400 PHOTO scanner works with SANE, but I cannot figure out
how.  What am I doing wrong?

Lincoln Peters <sampln@sbcglobal.net>