[sane-devel] sane frontend questions

Julien BLACHE jb@jblache.org
Tue, 13 Jan 2004 21:30:52 +0100

Andy Mitofsky <amitofsk@obiwan.csl.uiuc.edu> wrote:


> When I try to configure sane-frontends-1.0.11 I get the error 
> ****************************************************************
> WARNING: GTK-0.99.13 or newer is needed for compiling the GUI
> frontends. If you installed gtk as rpm make sure
> you also installed gtk-devel.
> ===> GUIs will be deactivated
> ****************************************************************
> However, I know I have gtk+-2.2.4 because I compiled it from the
> tarball. 

By default, sane-frontends up to 1.0.11 will build the gimp1.2 plugin
and thus will use GTK 1.2.

You have GTK 2 installed. If you want to build with GTK 2, run
configure --disable-gimp.

This will change in the next version of sane-frontends. It'll default
to GIMP 2.0 and GTK 2. (sane-frontends 1.0.12 will probably be
released after GIMP 2.0 final, unless Henning decides to make a
release sooner)


Julien BLACHE                                   <http://www.jblache.org> 
<jb@jblache.org>                                  GPG KeyID 0xF5D65169