[sane-devel] iscan: "Could not send command to scanner"

Olaf Meeuwissen olaf@epkowa.co.jp
Tue, 27 Jan 2004 14:32:10 +0900

Ole Jacob Taraldset <ojt@gexcon.com> writes:

> Hi,


> I have an Epson Perfection 1650 Photo which I have been using with
> iscan.  Now suddenly iscan doesn't work any more and just give me a
> dialog box saying "Could not send command to scanner".  Xsane still
> works and recognizes my scanner without any problems.
> My system is a RedHat 9 box with freshrpms updates and the following:
> sane-backends-1.0.9-5.1
> sane-frontends-1.0.9-2
> xsane-0.89-3
> iscan-1.5.2-1.redhat.8.0

Hmm, that ought to work provided the libsane.so symlink points to the
right library.  There is a known bug on RH9 where /usr/lib/libsane.so
points to the v4l SANE backend.  Check if this is the case and fix it
if so.

To check:

  $ ls -l /usr/lib/libsane.so

To fix (requires root permissions):

  # ln -fs libsane.so.1.0.9 /usr/lib/libsane.so

> I've also tried iscan 1.4, but get the same result.

Never mind that version.  It was very much not nice in that it quietly
overwrote the epson backend.

> My /etc/sane.d/epkowa.conf contains:
> usb /dev/usb/scanner0

That should be fine.

> My /etc/sane.d/epson.conf contains:
> usb /dev/usb/scanner0

For the record, iscan does not use the epson backend.  It is *not* a
proper SANE frontend in that respect.

> I have tried to remove one or the other but this doesn't seem to help.

Hope this helps,
Olaf Meeuwissen                            EPSON KOWA Corporation, ECS
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2