[sane-devel] HP5370C still not working

Henning Meier-Geinitz henning@meier-geinitz.de
Wed, 9 Jun 2004 17:18:18 +0200


On Wed, Jun 09, 2004 at 03:40:39PM +0200, Gilles Sadowski wrote:
> So, what is the final word about this "timeout" problem?

The reason is unknown as of now. It's not that easy as these timeouts
may have several reason. Every wrong command that's sent to the
scanner can cause timeouts.

It doesn't seem to be a general SANE problem. I've tried several
scanners on Linux 2.6.7-rc2 with UHCI, OHCI and EHCI USB host
controllers and can't reproduce the timeouts.

So someone who does see the timeouts needs to investigate the details.
E.g. if there is a specific SANE version that does work without
trouble. If that's the case, identify the change that causes problems.

If it depends on kernel versions, identify the kernel version that
started showing those timeouts.

I'll try to summarize what I've read here and in the bug tracking system:

- HP5370C (avision) on UHCI VIA, Linux 2.6.5
- HP7450C (avision), sane-backends 1.0.14 (also tried latest avision
  code), Linux 2.6.5
- HP7400 (avision) on UHCI (Intel Corp. 82371AB/EB/MB PIIX4 USB) Asus
  board, sane-backends 1.0.14, Linux 2.6.3, 2.6.5, 2.6.6 and
- HP7450C (avision), there was a hint about the hpusbscsi driver
  making trouble in that case
- Epson Perfection 1670 (snapscan) on UHCI VIA, sane-backends 1.0.14,
  Linux 2.6.5-mm2

No timeouts:
- Several Mustek+Plustek scanners (mustek_usb, plustek, gt68xx), 
  sane-backends 1.0.14, on OHCI + UHCI (VIA PCI card) on Linux 2.6.7-rc2
  and Linux 2.4.26
- Avision scanners, on OHCI, sane-backends 1.0.14 + latest avison code on Linux
  2.6.3 (UltraSparc +iBook)

Typical log:
Jun  6 19:06:11 localhost kernel: usb 1-1: bulk timeout on ep3in
Jun  6 19:06:11 localhost kernel: usb 1-1: usbfs: USBDEVFS_BULK failed ep 0x83 len 4096 ret -110

An unrelated bug showed the same timeouts:
- Epson Perfection 1260 (plustek), sane-backends-1.0.14, on Linux 2.6.7-rc2 
  and 2.4.25 with scanner.o(!)
Reason: the epson backend tries to talk to this scanner

There are some other reports about USB trouble but it's unclear if
they are related.

All these bug reports are newer than 6 weeks. So it's either the new
SANE, kernel, libusb release or some other part of software that got
changed recently.

All but one reports are about the avision backend. Maybe the trouble
is located there and the Epson 1670 problem has a different reason?