[sane-devel] Timeouts: usb_reset seems necessary to avoid bulk timeouts.

Olaf Meeuwissen olaf@epkowa.co.jp
Fri, 11 Jun 2004 13:50:39 +0900

Olaf Meeuwissen <olaf@epkowa.co.jp> writes:

> Tom Schutzer-Weissmann <misc@tomweissmann.org> writes:
>> On Thu, 10 Jun 2004 05:36:52 -0400
>> Karl Heinz Kremer <khk@khk.net> wrote:
>>> I'm also reading sane-devel, so no need to take a detour with
>>> any Epson backend related information :-)
>>> I've never experienced any of the problem you describe, and I've
>>> been running a 2.6.x kernel for some time now (SuSE 9.1 beta versions
>>> and the final SuSE 9.1).
>>> I've tried this with two different USB controllers (USB-1.1 and high
>>> speed USB-2) with a number of different Epson scanners.
>>> Karl Heinz
>> Thank you for all your responses.
>> I'm using Debian unstable, kernel 2.6.6 with ohci_usb, libusb-0-1.4
>> (0.1.8-11). The scanner is an Epson Perfection 2450.
> That's what you get for running bleeding edge ;-)
> I'm using Debian testing, kernel 2.6.6 with uhci_hcd (and ehci_hcd),
> libusb-0.1-4 (0.1.8-11) and will see if I can lay my hands on a
> Perfection 2450.
> The USB modules are autoprobed, I don't have anything USB related in
> my /etc/modules-2.6.  There is an usb-uhci in my /etc/modules but IIRC
> that file is not used if /etc/modules-2.6 exists.
>> It seems libusb isn't working as it should - maybe future Debian
>> updates will solve the problem; in the meantime I am happy with my
>> hack, but if anyone would like me to try out some suggestions to get
>> to the bottom of this mystery, I'd be happy to help off-list.
> As I'm using the same libusb as you do, I am sceptical about libusb
> being the culprit.  Apart from the usb module and scanner model, we
> use the same setup.  I'll get back with the results on the Perfection
> 2450 ASAP.

Problem confirmed for the GT-9700 (aka Perfection 2450) with both the
epson and epkowa backends.  Note that these same backends work fine
with the GT-8200 (aka Perfection 1650) under identical conditions.

Just starting a SANE frontend (tried with xsane and iscan) with the
GT-9700 already takes "ages" and it just refuses to preview.

BTW, the epson backend is from sane-backend-1.0.14 and the epkowa one
from iscan-1.8.1.

# The upcoming iscan-1.9.0 (due 2004-06-18), which adds support for
# the ES-10000G (aka Expression 10000) and adds saving in JPEG format,
# suffers from the same problem.

Looks like Karl and/or I have some digging to do ;-(
Olaf Meeuwissen                            EPSON KOWA Corporation, PF1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2