[sane-devel] Re: HP 5300C Xsane Failure

Rene Rebe rene@rocklinux-consulting.de
Sun, 27 Jun 2004 11:29:11 +0200 (CEST)


On: Sat, 26 Jun 2004 22:29:30 -0500,
    Myke Carter <mykec@mykec.net> wrote:
> OK.
> =

> First thing I tried was to uninstall "sane-backends-1.0.8-1.ximian.1"=

> =

> No go.

There is some switch to "force" the uninstall ... - but just
overwriting it is ok, too.

> Try 2:
> =

> ./configure --sysconfigdir=3D/etc --prefix=3D/usr
> =

> This caused my Gnome panel applet to crash and made it so that I =

> couldn't log out without hitting my reset button.  Running "xsane" =

> caused some kind of "relocation error" about a missing or bad =

> "<something>.so.1" file.  The error revealed something about "/etc/li=
b" =

> so before I rebooted I tried it once more.

This was the right configuration. When did the gnome-pannel crahs?
During make install?

> Try 3:
> =

> ./configure --sysconfdir=3D/etc --prefix=3D/usr/lib
> =

> This eliminated the previous problem but gave me new graphical dialog=

> box errors "No devices found." or something like that.  So I rebooted=

This configuration is very messy. /usr/lib is not a prefix you want
... Your binaries will be in /usrc/lib/bin and the libs in
/usr/lib/lib. This will not produces results you want - neither the
binaries nor libraries are found by your usual ld and PATH
configuration ...

> After rebooting, I restored my Gnome panel tasklist and tried again.
> =

> Now all I get is a dialogue box telling me "xsane: no devices availab=
> =

> Previously, with the old Ximian package that you said wouldn't work, =

> xsane was at least able to find my scanner.
> =

> What now?

You should install using your 2nd configuration.

What does this give you:

scanimage -L
scanimage -V


Sincerely yours,
  Ren=E9 Rebe
    - ROCK Linux stable release maintainer

--  =

Ren=E9 Rebe - Europe/Germany/Berlin
  rene@rocklinux.org rene@rocklinux-consulting.de
http://www.rocklinux.org http://www.rocklinux-consulting.de