[sane-devel] Problem with sane, HP5200 and libusb

Stefan Seubert Stefan.9@gmx.de
Fri, 05 Mar 2004 01:08:01 +0100

My HP5200C scanner used to work perfectly with the scanner.o kernel
module. Now I upgraded to kernel 2.6.3 and have to use libusb. Everytime
I try to scan with scanimage the output looks like the following:

# SANE data follows
2550 3507
scanimage: sane_read: Error during device I/O

On tty1 I get some of the following messages:

cannot get config descriptor: Connection timed out

And dmesg shows me some of these lines:

usb 5-2: control timeout on ep0in
usbfs: USBDEVFS_CONTROL failed cmd usbmodules dev 2 rqt 128 rq 6 len 18
ret -110

The Scanner is detectet by "scanimage -L" as "device `hp:libusb:005:002'
is a Hewlett-Packard ScanJet 5200C flatbed scanner".

The Scanner makes some noise like it is being initialized but it's not
scanning. I tried sane-backends 1.0.13 and the cvs snapshot from
2004-03-04 with the same results. I use libusb-0.1.8 and I have also
tried 0.1.7.

I don't know if this problem is related to sane or libusb. It would be
nice if someone here could help me with this.