[sane-devel] segmentation fault in xsane with epkowa

William P. Thompson w.p.thompson@att.net
Mon, 3 May 2004 11:18:35 -0400

Original message sent 4/29.

I thought I should report back on the solution, since the instructions on the 
epson website are confusing.

It appears now that the only thing needed is to add a new line: epkowa  to 
dll.conf, and to uncomment epson. I now get a choice between the two drivers.

It is not necessary to use the symbolic link.

Sorry for the confusion.

I downloaded the Epson Image Scan program (version 1.0.8-2 ) and converted the 
rpm to a deb. I am running Sarge through the Libranet Distribution. Using 
Sane version 1.0.10-1.

Following various instructions, I added epkowa to the dll.conf file and 
commented out everything else including 'epson'. I tried iscan but it did not 
work, however xsane and xscanimage worked perfectly.

Then I issued the following command after cd'ing to /usr/lib/sane :
ln -sf libksane-epkowa.so.1 libsane-epson.so.1.

Now iscan works perfectly and comes up in Xtns in gimp1.2, but xsane and 
xscanimage no longer work = segmentation fault.

I don't suppose I need those programs, but it would be nice to have them as a 

Yours posts of October 10-13 in the sane-devel list do not provide an answer 
to this problem.

Can you help?

Bill Thompson