[sane-devel] My Epson Perfection 636 (SCSI) no longer works?

Karl Heinz Kremer khk@khk.net
Sun, 7 Nov 2004 11:36:48 -0500

So it's not that the scanner all of a sudden did stop to work, you did=20=

change the configuration of your system? Recompiling the kernel=20
certainly qualifies for this.

What is /dev/scanner linked to? (Does not really play a role if you get=20=

the same behavor with "scsi EPSON", but if you have not tried to run as=20=

root when you are using "scsi EPSON" in the config file, it could be=20

On Nov 6, 2004, at 8:48 AM, Fr=E9d=E9ric Bri=E8re wrote:

>> Then your original log is not correct. These lines are from the debug
>> output that you provided:
>> [epson] sane_init, ># SCSI scanner:<
>> [epson] sane_init, >#scsi EPSON<
>> [epson] sane_init, >scsi /dev/scanner<
>> This is the output from grep that you posted:
>> [fbriere] toroia:~ $ grep -v '^#' /etc/sane.d/epson.conf
>> scsi EPSON
> You have a sharp eye.  I originally had compiled out /proc/scsi =
> in the kernel, so scanimage's debugging output was complaining about
> that.  I recompiled the kernel, rebooted, and ran scanimage again,=20
> which
> is the output I provided.  In the meantime, I played a bit with the
> config, hence the discrepancy with the earlier commands.
> [fbriere] toroia:~ $ grep -v '^#' /etc/sane.d/epson.conf
> scsi /dev/scanner
> Obviously, I tried both /dev/scanner and EPSON, and they give the same
> results (i.e. nothing).
> --=20
>              Fr=E9d=E9ric Bri=E8re    <*>    fbriere@fbriere.net
>  =3D>  <fbriere@abacom.com> IS NO MORE:  <http://www.abacomsucks.com>  =
> --=20
> sane-devel mailing list: sane-devel@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request@lists.alioth.debian.org