[sane-devel] saned refuses to reply

Olaf Meeuwissen olaf@epkowa.co.jp
Fri, 19 Nov 2004 18:33:57 +0900

I was wondering if someone could help me out.

Setup: sane-backends-1.0.13
       net backend enabled
       localhost uncommented in net.conf and saned.conf
       inetd.conf as per saned(8) manual page

Problem: saned does not seem to reply (except when in debug mode).

What I would expect is output like this:

  $ scanimage -L
  device `epson:libusb:002:003' is a Epson GT-8200 flatbed scanner
  device `net:localhost:epson:libusb:002:003' is a Epson GT-8200 flatbed scanner

I don't.  I only get the first line.

I confirmed with netstat that inetd is listening on port 6566.  Still
I don't get the output for the net backend.  Telnetting to port 6566
succeeds but kicks me out immediately.

I tried running saned in standalone mode (after stopping inetd).  It
immediately exists successfully (exit status 0).  That is:

  # saned && echo OK

Only when I run it with the -d flag do I get the output mentioned

Does anyone have an idea what might be wrong.
# Upgrading to 1.0.15 is likely not an option ...

Olaf Meeuwissen                            EPSON KOWA Corporation, PF1
FSF Associate Member #1962           sign up at http://member.fsf.org/
GnuPG key: 6BE37D90/AB6B 0D1F 99E7 1BF5 EB97  976A 16C7 F27D 6BE3 7D90
Penguin's lib!       -- I hack, therefore I am --               LPIC-2