[sane-devel] I have the Epson Perfection 2480 and 2580 for testing

Till Kamppeter till.kamppeter@gmx.net
Wed, 20 Oct 2004 01:59:05 +0200

Oliver Schwartz wrote:
> It seems the 2580 behaves somewhat different, although it uses the 
> same USB ID. Up to now I have no idea what's going wrong.
> The log you sent for the 2580 indicates an error in 
> snapscani_usb_open() which is only a small wrapper for 
> sanei_usb_open(). Can you provide logs with SANE_DEBUG_SANEI_USB=255 
> as well?

Here we go:


Coomand line was:

SANE_DEBUG_SANEI_USB=255 SANE_DEBUG_SNAPSCAN=255 scanimage > 1.pnm 2> 

1.pnm had 0 bytes after running this command.


>>Now I have tried to scan with the 2480 and I was even successful
>>sometimes. When it worked the problem was that there were long
>>delays until the scan to start (command line) or the GUI to appear
> The delays are annoying, but it seems that all delays are requested by 
> the scanner. You can try to reduce the number of retries for the 
> test_unit_ready in snapscan-scsi.c, line 1008 and see if that works 
> any better.
>>On all later attempts I got a segmentation fault when the GUI
>>started to open. The command line was the following:
> There's nothing obvious in the log. Can you run xsane in gdb and 
> create a stacktrace (command "bt" IIRC) after the crash?
> /Oliver