[sane-devel] Problem scanning with Kooka/Epson Perfection 2400

Steven P. Ulrick ulrick2@faith4miracle.org
Fri, 29 Oct 2004 00:39:16 -0500

Hello, Everyone
I am having a problem scanning with our Epson Perfection 2400 scanner. =A0I=
don't know for sure if this is a KDE issue or not.  But I figured that sinc=
the Scanner Guru's are here, that at the very least you could tell me if th=
is a problem with SANE or not.

This problem only occurs when I use Kooka (doesn't matter whether it's the=
version that ships with Fedora Core 2, or the one on CVS HEAD.) =A0I tried=
scanning an image earlier using xsane, and it worked just fine.
Here is a link to an image that I Just scanned (using "xsane", to show that=
the scanner works just fine:

When I start any version of Kooka (for this experiment, I will start Kooka=
while su'd into root. =A0This is what the GUI looks like:

Then I proceed to do a "Preview Scan" =A0This is what the GUI looks like th=

If I try to do a "Final Scan", this is what the GUI looks like:

You will notice that these are identical screen shots. =A0This is because=20
whether I choose "Preview Scan" or "Final Scan", nothing appears to be=20

The only configuration file I could find was in "~/.kde/share/config" =A0I =
deleting that and retrying what I described above, to no avail.

At the following location, you will find a tarball of the terminal window=20
outputs that I got when I tried a Preview and a Final scan. =A0In the same=
tarball, you will find straces of attempts at Preview and Final scans.

Root is the group and user of /proc/bus/usb/001/013
Also, root does have read, write and execute permissions on this device.
One thing I just thought of: I can't remember for sure, but should I have=20
a /dev/scanner? =A0I can't remember if I had one in the past, or if that is=
relevant with a USB scanner. =A0All I know is that I don't have one now.

Operating System: Fedora Core 2, All Packages installed, All official Updat=
installed (Except the kernel)
QT: 3.3.3 from TrollTech source tarball

QT and KDE paths are both exported in my ~/.bash_profile. =A0I did not over=
the FC2 default KDE.

In closing, this same scanner, using Kooka from the CVS HEAD version of KDE=
used to work perfectly, never giving me a moment of trouble. =A0Like I stat=
earlier, and proved with an example for your viewing, this same scanner tha=
does not work with kooka, does work just fine with xsane.

I will be glad to answer any questions that this problem might require.

Have a Great Day
Steven P. Ulrick
 00:36:39 up 16 days, 10:06, 45 users,  load average: 0.34, 0.33, 0.67