[sane-devel] Problems with scsi filmscanner canon2700

Thomas Loescher mailgrab@gmx.de
Tue, 21 Sep 2004 01:03:01 +0200


On Tue, 21 Sep 2004 08:34:26 +0200 (METDST)
Ulrich Deiters <ukd@xenon.pc.Uni-Koeln.DE> wrote:

> I am sorry for the problem, but it appears that the
> introduction of focus controls for the Canon FS2710
> somehow disrupted the focus controls for the FS2700.
> Unfortunately, I do not have an FS2700, and so I
> cannot test the backend for this scanner.
> If you say that sane version 1.0.13 worked for you,
> this gives me a clue where to start hunting for the
> bug. But please don't expect a quick answer.

I tried yesterday also sane-backend 1.0.13 and it also didn't work. :-(
Didn't matter what kernel I used. I tried Kernel 2.4.22, 2.4.24 and 2.4.26
Really don't know, how to start debung...
I would really like to help you in fixing this problem, but I don' know how to do.
If you want me to test some CVS-code or something like this fell free to ask me.
Should I try any older sane-backends?

> As a workaround you can copy the relevant files 
> (canon.c, canon-sane.c, canon-scsi.c, canon.h)
> from the 1.0.13 version to your actual backend
> directory and recompile. That should help, provided
> that the bug is where we think it is.
as mentioned above, sane-backend 1.0.13 also didn't worked.
Should I try this in case of this fact?

> Best regards,
> Ulrich Deiters
thanks for helping me with this problem

best regards


> -- 
> sane-devel mailing list: sane-devel@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request@lists.alioth.debian.org