[sane-devel] Re: Re: Sane problem with ADF on Epson Perfection 1640SU

Terje J. Hanssen nteknikk@monet.no
Sun, 26 Sep 2004 15:47:47 +0200

I can now confirm that also I have succeeded (at last!) to get my Epson
ADF scanner to work with Xsane. After I got copy of the previous
libsane-epson.so.1.0.8 from Suse Linux 8.1, I followed the suggested
installation procedure below to apply it on Suse 9.1.

As libsane-epson.so.1.0.8 shows to work with ADF, maybe this makes it 
easier to debug the current libsane-epson library (?)

Terje J. Hanssen

Terje J. Hanssen wrote:

> I just got the following mail from a reader of my August mail about this
> problem. It looks like the ADF problem is related to newer versions of
> the libsane-epson library, as the previous version 1.0.8 worked and 
> works, see below.
>> Flatbed scanning works, but trying to use the ADF results in the
>> following error: "Failed to start scanner: Error during device I/O",
>> and no scanning starts. (Just to verify that the ADF works: the
>> included scanner software, Epson Smartpanel for scanners and Epson
>> Twain5, works ADF scanning in Windows).
> *I had the same Epson ADF problem, using Suse linux 9.1. Flatbed scanning
> worked fine. Previously using Suse 8.1 the ADF worked fine. I then found
> that the problem is with version 1.0.13 of the epson sane library. I
> solved the problem by downgrading this library to version 1.0.8 (that I
> had in Suse 8.1). Now the ADF works fine.
> For doing that, I copied the old
> /usr/lib/sane/libsane-epson.so.1.0.8
> to the /usr/lib/sane/ directory, and relinked the symbolic links
> /usr/lib/sane/libsane-epson.so and /usr/lib/sane/libsane-epson.so.1 to
> it, instead of to /usr/lib/sane/libsane-epson.so.1.0.13.
> Then performed ldconfig.
> I did not check version 1.0.14 of sane.