[sane-devel] umax_pp slow

Joe Henley joehenley@kc.rr.com
Thu, 30 Sep 2004 16:42:43 -0500


Thanks very much for your reply.  I changed my umax_pp.conf file to read:
option buffer 8388608
port 0x378
option astra 2000

Then I ran the export command, then the scanimage command.  The log 
contents are:
[sanei_debug] Setting debug level of umax_pp_low to 1.
[umax_pp_low] SANE_INB level 3
[umax_pp_low] sanei_umax_pp_InitPort(0x378,)
[umax_pp_low] sanei_ioperm(0x378, 8, 1) OK ...
[umax_pp_low] UMAX Astra 1220/1600/2000 P ASIC detected (mode=31)
[umax_pp_low] registerRead, found 0xFF expected 0x00 (umax_pp_low.c:6633)
[umax_pp_low] *** It appears that EPP data transfer doesn't work    ***
[umax_pp_low] *** Please read SETTING EPP section in sane-umax_pp.5 ***
[umax_pp_low] Hardware can't do ECP, giving up (umax_pp_low.c:6856) ...
[umax_pp_low] No EPP or ECP mode working, giving up ... (umax_pp_low.c:7475)

The results surprised me.  I ran ppdiag to check and got:
S01: parport built as module
S02: parport0:
S02:    ADDR :0x378
S02:    IRQ  :no IRQ used
S02:    DMA  :no DMA used
S03: no parport parameters
S10: ppdev built as module
S12: /dev/parport0 exists ...
S12: /dev/parport0 is readable ...
S12: /dev/parport0 is writable ...
successfull end ....

I double checked my BIOS and it's set to EPP, port 378 and IRQ 7.

So now I'm really stumped.  Please point me in the right direction.

If it's relevant:  using RedHat 9, kernel is 2.4.20-20.9, xsane is 
version 0.96, sane-backend is: 1.0.14 with the 6.3 patch for umax_pp, 
mobo is an Intel 875PBZ.


PS:  Sorry about RoadRunner blocking your replies.  I don't know why.

svoltz@wanadoo.fr wrote:
> On Wed, Sep 29, 2004 at 04:05:33PM -0500, Joe Henley wrote:
>>I got the lastest version (patch) of umax_pp working on the latest 
>>version of Sane and XSane; those, in turn, run on Red Hat 9 Linux.  I'm 
>>using an Astra 2000P scanner.  The umax_pp config file uses:  port 
>>/dev/parport0.  The BIOS is set for EPP (ECP is not available in my BIOS).
>>When I try to scan something at 300 DPI the scanner does a "four steps 
>>forward, one step back" dance.  It takes a long time to complete the 
>>scan.  If I scan at 150 DPI, the scanner does it all in one pass, 
>>without the "dance."  If I dual boot into Win98 and use the scanner at 
>>300 DPI, no dance.
>>Does anyone know how to get my scanner to scan at 300 DPI quickly, in 
>>Linux -- like it does in Win98?
>>Thanks for any suggestions!
>>Joe Henley
> 	Hello,
> 	faster scan speeds are reached with direct hardware access. 
> You can change this in the umax_pp.conf file, set the 'port' option
> to the address of your parallel port.
> 	By default, the umax_pp backend tries to use ppdev which does
> an extra data copy form kernel to usespace and slow down scans. You can
> also check that your parallel port allows 4 bytes writes. In a command
> shell do 'export SANE_DEBUG_UMAX_PP_LOW=1', then do 'scanimage -L 2>log'.
> When finished search in it for a line :
> [umax_pp_low] 32 bits EPP data transfer 
> 	If you don't have it, it is certainly because your parallel port 
> is not correctly set by the kernel. In this case, using direct hardware
> access may get around it.
> Regards,
> 	Stef
> P.S. Got the mail you sent me, but couldn't answer because
> http://security.rr.com blocked my mail.