[sane-devel] Plustek hangs on OS/2 - part II

Paul Smedley paul at smedley.info
Tue Aug 16 11:18:39 UTC 2005

Hi Gerhard!

Gerhard Jaeger wrote:
> On Tuesday 09 August 2005 12:27, Paul Smedley wrote:
>> Oh & I forgot to mention - in the logs that 'beep' there's a return code 
>> (32772) from usbbulkread that says 'less data than requested returned'. 
>>   In this case, 1 byte was requested and 0 returned.....  log excerpt 
>> below shows what the backend does when this occurs.
>> [sanei_usb] sanei_usb_read_bulk: rc = 32772
>> [plustek] UIO error
>> [plustek] Calibration file-name set to:
>> [plustek] >E:\tcpipapp\home/.sane/Canon-N670U_N676U_LiDE20.cal<
> I also got this UIO error sometimes here on my linuxboxes, but they don't
> seem to disturb. Well in the meantime, I tried to figure out, when this
> UIO error occurs. In the end it only occurs during power-up of the scanner,
> directly after pluging it in. So I did some changes to the setup procedure
> and managed to make these UIO errors disappear on my boxes.
> Could you please checkout the latest CVS stuff and test on your OS/2 box?

Thanks for the tar.gz of the plustek*.*

Great news - the UIO error is gone - I still get a beep from the PC 
speaker the first time the device is accessed - however I've not seen 
any hangs on 10 or so scans - including unplugging/replugging the 
scanner to try and trigger it.

Thanks for your help!



More information about the sane-devel mailing list