[sane-devel] Umax Astra 2200 under OpenBSD?

alancorey at yahoo.com alancorey at yahoo.com
Tue Aug 16 18:15:13 UTC 2005

I'm trying to get a Umax Astra 2200 (using USB)
working under OpenBSD 3.6 using sane-backends-1.0.16. 
I'm not sure whether this backend tries to use libusb
or not.

sane-find-scanner finds a USB scanner but can't
identify it.  I have uscanner enabled in the kernel
and the scanner gets found as /dev/uscanner0 as it
seems it should.  If I disable uscanner in the kernel
it doesn't get found at all. 
/usr/src/sys/dev/usb/uscanner.c lists this among its
devices but that may only be for the sake of
identifying USB vendors and devices.

The status of libusb is unknown.  I installed
libusb-0.1.7p2 from the OpenBSD ports collection, but
Sane seems to not be finding or using it.  Doing a
locate libusb shows these files installed:
At first I didn't have libusb installed, but after
installing it I did a gmake uninstall, then gmake
distclean, then configured and installed Sane over

According to sane-backends-1.0.16/README.openbsd I may
have to add the vendor and device IDs to
sys/devs/usb/uscanner.c and rebuild the kernel.  I've
made a couple of tries at that but I'm not quite sure
where to put them.  C isn't my favorite language, and
I'm rusty at pointers to structs.  It compiles and
everything, but didn't seem to have any effect.  I
added these: 0x1606 0x0230 for vendor and device, or
tried to.

The machine is a Dell CPIa laptop.  USB works well on
it under OpenBSD, and I routinely use an external USB
CD burner and a couple of those USB flash/pen drives. 
Those worked even without libusb.

I'm not sure whether I should be trying to
troubleshoot uscanner or libusb because I don't know
whether libusb is used or not.  It would be useful to
have the backend description tell whether it uses
libusb or not, but maybe it depends on the platform.


Start your day with Yahoo! - make it your home page 

More information about the sane-devel mailing list