[sane-devel] Problems with Canon LiDE 30 (sane-backends-1.0.16, kernel

Michal Kepien lordpopcorn at poczta.onet.pl
Fri Aug 19 09:43:16 UTC 2005

Hi there,

I've been successfully using SANE with my Canon LiDE 30 scanner for quite a long
time. Yet, when I came back from holiday, I've updated my system, Slackware 10.0
+ slackware-current, and so I've migrated from kernel to and
from sane-backends-1.0.15 to sane-backends-1.0.16. After doing that the scanner
stopped working. Here are the details: sane-find-scanner works ok and detects
the scanner connected to the USB port. However, `scanimage -L' tells me that "No
scanners were identified". I'm using the plustek backend as suggested by the
SANE Supported Scanners Search Engine. So I've tried to debug the thing and
though set both SANE_DEBUG_SANEI_USB and SANE_DEBUG_PLUSTEK environmental
variables to 255. The `scanimage -L' debug output can be found here:


The line that draws my attention is the one containing "Inappropriate ioctl for
device" message. Looks like the scanner is correctly detected even by the
backend itself (it's listed as an "available and supported device"), yet there
is no communication with it. I don't know whether this is a SANE bug, or a
kernel update matter, or finally a configuration error (this is unlikely IMHO,
everything worked perfectly before).

Shall anyone come across any tips, please inform me.

Best regards,
Michal Kepien

More information about the sane-devel mailing list