[sane-devel] Configuring a Mustek BearPaw 2400 Scanner

Richard Ibbotson richard.ibbotson at gmail.com
Fri Aug 19 15:29:19 UTC 2005


Just got hold of a Mustek BearPaw 2400 CU Plus scanner for my own
Debian Sarge workstation with a Debian kernel.  The scanner
plugs in with USB.  Seems to be detected and works.  Output of
'scanimage -L' shows....

" device `gt68xx:libusb:002:016' is a Mustek BearPaw 2400 CU Plus
flatbed scanner "

Before I plugged it in I found the driver from the
www.sane-project.org site.  After grabbing the gt68xx driver I
noticed that this was on the driver page...

" If you can only scan half of the page, use the PS2Dfw2.usb firmware
and rename it to PS2Dfw.usb. "

What I can see as the output which is in PNG or PNM or TIFF format is
that the scanned images are coming out stretched in the horizontal


So that a square OpenBSD CD cover comes out as a horizontal rectangle. 
Also, only half an A4 page is being scanned which is also stretched
in the horizontal direction.  I've tried to rename the ps2dfw2.usb
driver in the way that is described above.  The scanner/driver just
crashes and sits still.  To test the scanner and driver I was using
the following command line argument...

scanimage  --mode col>/home/user/scanner/image.png

Does anyone know how to fix these problems ?  I don't want to return
the scanner because it does work and does put out some useful images. 
Just that it's not quite right somewhere.  Also, I've tried Xsane and
Quiteinsane and neither of those applications will detect the scanner
even though it is seen by the command line software.  I think this
might be something to do with permissions and the fact that only the
root user has access to the scanner.  I'm not quite sure how to fix
that.  Any help appreciated.





More information about the sane-devel mailing list