[sane-devel] Can someone help me with getting my Mustek 1200 ED scanner working?

Manuel Reimer MReimer at despammed.com
Wed Aug 24 17:46:13 UTC 2005


I've tried several things now to get my scanner working, but without 
too big success.

My first try was SANE, which would also have been the best solution, 
but the "mustek_pp"-Backend only is able to switch on the light and 
"tries" to move the enging without success.

At second I tried WINE. Wine is able to display the frontend of my 
scanner driver and it "fakes" scanning, but the scanner does nothing. 
The reason seems to be "msfcepp2.vxd" which seems to fail with wine.

The third try was a virtual machine. As I don't want to buy VMWare 
just to get my old scanner running I patched qemu using a patch I 
found in the mailing list. I also tried to improve the code added by 
the patch, but I never succeeded with getting my scanner to scan.

I'm willing to help where I can if there is any driver programmer here 
wo wants to spend some time with that, but I'm no "driver developer", 
I never developed any drivers so far, but I have some (minor) 
C++-Knowledge. As mentioned I would help where I can, but I can't 
write a driver on my own.

If noone wants to help me, then it would help me if someone gives me 
some information about msfcepp2.vxd. I think for a "driver development 
newby" like me it would be easiest to try to port msfcepp2.vxd to 
linux to get the mustek drivers running with Wine.

Thank you very much in advance for any answer and for any help



More information about the sane-devel mailing list