[sane-devel] Very Old Horse: HP ScanJet 5370C Now Gives I/O Error

Dan McGhee beesnees@grm.net
Mon Jul 4 19:59:06 UTC 2005

Once again I'm attempting to get my 5370C working in SANE.  I am using a 
LinuxFrom Scratch build with kernel  I currently don't know 
whether this is specific to avision or whether it is a "general" 
backends situation.

This morning I started with the stable releases of both sane-backends 
and sane-frontends.  The only problem I had was vertical blue stripes on 
the "preview" image--I did not scan to a file since this is a problem 
I've had before with the stable release and the final image had the same 
stripes.  This a similar situation is documented in Bug # 301814.

I then rebuilt sane-backends using Build 250 of avision.{c,h} (along 
with sanei_usb.{c,h}) from the current SVN trunk.  Now I have the 
following symptoms:

1.  I must restart (off-on) my scanner for either scanimage or 
xscanimage      to recognize it.
2.  When I try to do a preview scan in xscanimage I get an error         
        "Failed to start scanner:  Error during device I/O

Here is the edited output of xscanimage:

[sanei_debug] Setting debug level of xscanimage to 4.
[xscanimage] main
[xscanimage] xscanimage (version: 1.0.13, package: sane-frontends) starting
<deleted 8 lines>
[xscanimage] update_param
[xscanimage] update_param: finished
[xscanimage] pref_device_restore
[xscanimage] device_dialog: finished
[xscanimage] interface: now running gtk_main ()
[xscanimage] scan_preview
[xscanimage] scan_preview: finished
<this is the point at which I clicked "Preview" in the preview window>
[xscanimage] scan_preview
[xscanimage] scan_preview: finished
<Received error message and acknowleged it>
[xscanimage] quit_xscanimage
[xscanimage] pref_xscanimage_save
[xscanimage] pref_xscanimage_save: finished
[xscanimage] quit_xscanimage: exiting

Then I ran  'scanimage -v -v -v' with the following results:

scanimage: scanning image of size 2544x3489 pixels at 24 bits/pixel
scanimage: acquiring RGB frame
scanimage: min/max graylevel value = 255/0
scanimage: sane_read: Error during device I/O
Closing device
Calling sane_exit
scanimage: finished

Bugs 300868 and 301592 may be related to this.

BTW I ran all of these commands as 'root' to eliminate the possibility 
of permission errors.

While I was "googling" this morning I found a post at the "Nottingham 
LUG List" (http:/shoe.bocks.com/nlug/2005-Feb/6512.html).  The post was 
in response to trouble with an HP 5370c and SANE.  In response to:

> If I run x-sane, it occasionally starts up and goes on to give 
> something like:, but normally gives something like:
> unable ot start device: I/O error
> but normally gives something like:
> no devices available. 

an individual responded:

> A common thing missing is that you need to copy the (windows) *.bin
> (firmware) file for your scanner somewhere so that it can be uploaded
> into the scanner at startup. There should be a pointer in the sane
> config file to do this for your scanner. 

Is this a valid suggestion?  If so, how do I incorporate it into my 

If this is not a valid suggestion, how can I turn on more debugging to 
help diagnose and rectify this situation?  I had the same "blue line" 
symptoms in Mandrake 10.1.  Just to verify that the scanner works, I can 
scan in Mandrake with Vuescan and in Windoze with the hp utilites and gimp.

I will be more than happy to supply output and images.  I just need to 
know what to do.



More information about the sane-devel mailing list