[sane-devel] Re: scanning hangs 1/4 of the way

Carlos Rodrigues carlos.efr@mail.telepac.pt
Sun, 06 Mar 2005 19:19:38 +0000

Carlos Rodrigues wrote:
> Hi!
> I've been using sane (1.0.14) for some time on a Red Hat 9 machine which 
> acts as a scan server for a Mustek Bearpaw 1200.
> But now it doesn't work, if I try to scan from a client workstation, the 
> scanner stops about 1/4 of the way and the client (xsane) hangs. If I 
> "kill -9" saned, the scanner returns to the start position and the 
> client exits.
> If I try to scan using "scanimage > xpto" on the server, it goes to the 
> exact same spot (1/4 of the way) and returns to the start position, like 
> if it did the complete job.
> I've tried to upgrade sane-backends to 1.0.15 and changed the usb access 
> method from "kernel" to "libusb" to no avail.
> I've also tried to run saned with "-d128" and set the usb debugging to 
> 128 also, but I see no errors, it just hangs.
> I was just about to declare the scanner as dead when I went and 
> connected it to my Fedora 3 (sane-backends 1.0.15) box and it works fine.
> There was a recent fedora-legacy update for the kernel, but I rolled it 
> back to the previous (known to work) version to no avail...
> I'm stuck, any ideas?

Ok, I found the problem... apparently it isn't enough to open port 6566
on the firewall I've recently configured...

But, I have another issue. Using the kernel scanner driver it scans
fine, but using libusb it its the scanning head hits the end and makes
some creaking noises.

sane-backends 1.0.15
libusb 0.1.10
kernel 2.4.20-42.9.legacy (Red Hat 9)

Carlos Rodrigues

url: http://tudo-sobre-nada.blogspot.com