[sane-devel] Problem with GT68XX and MacOS X REVISED

Henning Meier-Geinitz henning at meier-geinitz.de
Tue Nov 22 16:39:18 UTC 2005


On Tue, Nov 22, 2005 at 02:43:22PM +0000, Nick Collingridge wrote:
> G5 Dual 2GHz, 2GB RAM
> MacOSX 10.4.3
> Scanner ­ Mustek A3 USB
> LibUSB ­ 0.1.11
> SANE Backends - 1.0.16

There are some issues with the A3 USB in 1.0.16 which have been fixed
in the current development version of sane-backends. But as far as I
know, none of these issues were related to detection of the scanner.
Trying a current development snapshot may be woth a try anyway.

> I have installed all the above items and made sure that there is a properly
> configured (according to the instructions, including an override and a
> vendor and model number) GT68xx.conf file in /usr/local/etc/ on my boot
> drive. 

This scanner does not need an override. Vendor and product ids are
already in gt68xx.conf.

> Also a firmware file (a32fw.usb) in /usr/local/share/sane/gt68xx/.


> However I still can¹t get the scanner to work. The symptoms are:
> Using sane-find-scanner in Terminal I get:
>     found USB scanner (vendor=0x055f, product=0x0210 [USB Scanner],
> chip=GT-6816) at libusb:009:004-055f-0210-00-00
> Then if I try scanimage ­L I get a message starting ³No scanners were
> identified...²

This is strange. scanimage -L doesn't do much more that
sane-find-scanner in this case.

Just to be safe, please disable everything except "gt68xx" in

Please send the output of
export SANE_DEBUG_GT68XX=255 (or Mac OS X equivalent)
scanimage -L

> But irrespective of when I power-cycle, if I try scanimage > test.pnm, I
> get:
>     scanimage: no SANE devices found

Please send also a log file of this attempt (as above).

> I am confused and don¹t know where to go next. I think there is an issue
> here with the scanner having to be power-cycled after every command (is this
> a bug?), but even if I try and actually scan an image immediately after
> power-cycling, it still doesn¹t work.

You are not expected to power-cycle the scanner each time :-)
This doesn't happen on Linux or any of the BSDs and I also haven't
gotten a report about such behaviour on Mac OS X as far as I remember.

> I am afraid that all the man pages and the FAQ for TWAIN SANE are not very
> complete in their description of what needs to be done to get everything
> working properly, and also don¹t really help very well when things don¹t
> work.

man sane contains some trouble-shooting notes.

> They just do not describe the combination of circumstances I am
> experiencing.

This is because you are the first one to report this problem.

> Also they are clearly written mainly for Linux users and much does
> not directly transfer to MacOS X.

The documentation is written mainly for Unix users. It's clear that
device file names vary between Unix systems but usually it's noted if
something is os-specific. At least it should :-)

> The really frustrating thing is that when I installed SANE on a previous
> MacOS X system it worked fine (within its limits!). I just can¹t get it to
> work again with the latest versions of all the s/w.

Do you remeber which version was used on your previous Mac OS X system?

Generally, the gt68xx backend works on MacOS X as I got positive
feedback about that.


More information about the sane-devel mailing list