[sane-devel] Problem with GT68XX and MacOS X

francois baert francois.baert at wanadoo.fr
Wed Nov 23 09:23:40 UTC 2005

Le Mardi 22 Novembre 2005 15:38, Nick Collingridge a écrit :
> Summary of configuration:
> G5 Dual 2GHz, 2GB RAM
> MacOSX 10.4.3
> Scanner ­ Mustek A3 USB
> LibUSB ­ 0.1.11
> SANE Backends - 1.0.16
> I have installed all the above items and made sure that there is a properly
> configured (according to the instructions, including an override and a
> vendor and model number) GT68xx.conf file in /usr/local/etc/ on my boot
> drive. However I still can¹t get the scanner to work. The symptoms are:
> Using sane-find-scanner in Terminal I get:
>     found USB scanner (vendor=0x055f, product=0x0210 [USB Scanner],
> chip=GT-6816) at libusb:009:004-055f-0210-00-00
> Then if I try scanimage ­L I get a message starting ³No scanners were
> identified...²
> Following this I have to power-cycle the scanner before it is recognised by
> sane-find-scanner again.
> If I try scanimage ­L immediately after power-cycling the scanner, I get:
>     device `gt68xx:libusb:009:004-055f-0210-00-00' is a Mustek ScanExpress
> A3 USB flatbed scanner
> But irrespective of when I power-cycle, if I try scanimage > test.pnm, I
> get:
>     scanimage: no SANE devices found
> I am confused and don¹t know where to go next. I think there is an issue
> here with the scanner having to be power-cycled after every command (is
> this a bug?), but even if I try and actually scan an image immediately
> after power-cycling, it still doesn¹t work.
> I am afraid that all the man pages and the FAQ for TWAIN SANE are not very
> complete in their description of what needs to be done to get everything
> working properly, and also don¹t really help very well when things don¹t
> work. They just do not describe the combination of circumstances I am
> experiencing. Also they are clearly written mainly for Linux users and much
> does not directly transfer to MacOS X.
> The really frustrating thing is that when I installed SANE on a previous
> MacOS X system it worked fine (within its limits!). I just can¹t get it to
> work again with the latest versions of all the s/w.
> Do I need to provide any further info, or can someone give me some pointers
> on what I need to do to get things going beyond where I have got to?
It's amazing
I got the same pb with an epson scanner (GT-7000) using Fedoracore 4.
kernel 2.6.11.
On a redhat 9.0 xsane works fine.
Besides I observe that the driver=none in the file /proc/bus/usb/devices
When I submit xsane every thing seems O.K. at the beginning but the program 
hangs and after a while I got this message:
failure to start the scanner Error I/O on the peripherical

I saw today that an other guide Mike Brodbelt has about the same Pb with an 
espson scanner using a kernel 2.6.14 mine is 2.6.11 ??? xsane 0.95
xsane-0.89 works fine on a redhat 9.0 kernel 2.4.20.

Pb could be related to libusb ???

More information about the sane-devel mailing list