[sane-devel] Genesys HP scanjet 2400

carlos carlos at superkaos.jazztel.es
Wed Apr 19 21:38:43 UTC 2006

On 06/12/05 22:30, Stéphane VOLTZ wrote:
> 	Hello,
> 	sorry to have taken so long to answer, but I have little time and many things 
> to do ... However, I believe it isn't helpful to modify the warmup that way. 
> You have to set up the right register values instead. Also, you have to make 
> sure that the scanner is using an area suitable for it, if the head is on a 
> black area, no warmup will succeed.
> 	If I had enough time, here's how I'd do:
> 	- get a windows usb log of a colour preview, just after powering-up scanner
> 	- extract from it the values to put in genesys_devices regarding constants in 
> 		Genesys_Frontend, Genesys_Sensor, Genesys_Gpo, Genesys_Motor. 
> 	        Current values	aren't considered exact, testing is needed.
> 	- by running scanimage with full debug and comparing it's output with decode
>     	       usb log, modify the genesys_gl646.c file to take 2400 specifics  
>                into account. Every places where is a xxx_HP2300 constant is a
>                candidate.
> The HP2300 and MD5345 use a method to build slope tables which is superseded 
> by the method used for GL841 parts. This newer method should be preferred. 
> That involves using the newer exposure time comptuing function.
> 	I again attach the scripts I use to turn an usb log into something more 
> suitable for developpement. I tested it on HP2400 logs I have. I think have 
> all the elements to finish support for 2400 but I'm missing an essential 
> thing: the scanner itself.

    I have tried to use your awk scripts on the windows usb logs. There seems to
be a missing file from your tarball, here's what I get when I run decode.sh:

reformatting data ...
compacting URBs ...
sorting ...
depacking ...
parsing ...
awk: fatal: can't open source file `parse1.awk' for reading (No such file or directory)
executing motor2.awk...
executing genesys_get_status.awk...
executing testR70.awk...
executing genesys_fe_write_data.awk...
executing genesys_set_buffer_address.awk...
executing genesys_set_buffer_address2.awk...
executing genesys_read_feed_steps.awk...
executing genesys_bulk_write_data.awk...
executing genesys_bulk_write_next.awk...
executing genesys_bulk_read_data.awk...
executing genesys_bulk_read_next.awk...
executing genesys_bulk_write_register2.awk...
executing genesys_bulk_write_register.awk...
executing genesys_read_register.awk...

Needless to say I get an empty output file.


Public PGP: http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x56FAE049

Q:      What is the difference between Texas and yogurt?
A:      Yogurt has culture.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20060419/33f55677/attachment.pgp

More information about the sane-devel mailing list