[sane-devel] lexmark x1170 @Mdk2005 installed but not detected

Fred Odendaal freshshelf at rogers.com
Fri Feb 3 23:46:50 UTC 2006


When you compiled did you do a "./configure", "make" and a "make 
install". The "make install" will probably have to be done as root as by 
default it installs in /usr/local/lib/sane, which usually isn't 
writeable by users.

If you did this and scanimage isn't finding your scanner, it's probably 
because it's looking for the sane backend libraries in a different 
place. On my machine (Fedora Core 4) the frontends expect the libraries 
to be in /usr/lib/sane. You can get the libraries to install there by 
redoing your compilation, but adding "--prefix=/usr" to configure. For 
example, the new compilation commands would be:
./configure  --prefix=/usr
make install

Another thing that can happen, is that the usb interface gets confused. 
Simply unplugging and plugging in the usb cable fixes this.

Hope this helps...
Fred Odendaal

patek wrote:

> Hi,
> I am a newbie but I tried really hard to get my x1170 working as this 
> is a gift from my cousin:P
> I managed to download the drivers from cvs (never did this before) and 
> compile them. When I type sane-find-scanner, I get
> (...)
> found USB scanner (vendor=0x043d, product=0x007c) at libusb:001:004
> (...)
> but when I try to run scanimage -L: "No scanners were 
> identified.(...)". Kooka and Xsane don't detect it as well, no matter 
> if it is on or off.
> I have tried to search through the archives and googled a lot, but 
> failed to finf anything.
> Do you have any ideas?
> Thanks for your work, guys! Regards
> patek (Poland)

More information about the sane-devel mailing list