[sane-devel] using parallel port scanner as ordinary user in recent version of Fedora

m. allan noah anoah at pfeiffer.edu
Tue Jul 11 19:24:19 UTC 2006

so add your father's account to group lp?


On Tue, 11 Jul 2006, Andre Robatino wrote:

> m. allan noah wrote:
>> this is just a permissions problem? can you get the udev subsystem to set 
>> the mode of the parport file to something more permissive?
> It's definitely a permissions problem.  The permissions on /dev/parport0 
> are:
> crw-rw---- 1 root lp 99, 0 Jul 11 13:19 /dev/parport0
> Prior to udev we simply changed the permissions to 666 and that worked.  On 
> my Fedora box, I tried editing /etc/udev/rules.d/50-udev.rules by changing 
> the permissions in the line
> KERNEL=="parport*",             GROUP="lp", MODE="0660"
> to 666.  This didn't work - after rebooting, the permissions are still 660. 
> I read something somewhere about this having something to do with pam 
> security which I don't know anything about.  It seems that figuring out how 
> to change the permissions to 666 will be at least as difficult as finding out 
> how to do this the "right" way.

"so don't tell us it can't be done, putting down what you don't know.
money isn't our god, integrity will free our souls" - Max Cavalera

More information about the sane-devel mailing list