[sane-devel] A problem with permissions

Julien BLACHE jb at jblache.org
Mon Mar 13 17:18:34 UTC 2006

John Missing <programming.student at verizon.net> wrote:

> I've been configuring things on my machine running Debian and have been
> doing well with the exception of one nagging problem: getting SANE to
> run on my user account. When I log into root, it works perfectly, but,
> when I'm logged in as a user, it crashes without any identifiable error.
> The user is in the saned and scanner groups. I have tried to check
> every file and directory to find the one that does not have permission
> set for the user, but I seem to be missing something. Could someone
> suggest somewhere that I might not have thought to look?

You need either udev or hotplug installed, assuming your scanner is
USB and its IDs are known by the version of SANE you're using.

If it still doesn't work, please provide more information: scanner,
libsane version would be a good start.


Julien BLACHE                                   <http://www.jblache.org> 
<jb at jblache.org>                                  GPG KeyID 0xF5D65169

More information about the sane-devel mailing list