[sane-devel] problem with Epson perfection 2480 photo scanner in FreeBSD

breach0r breacher at telenet.be
Thu Mar 23 14:18:42 UTC 2006


I tried, now sane-backends-1.0.16_2 is installed, i still get I/O error when 
trying to init the scanner. I/O error the first try and device unavailable the 
next tries. set SANE_DEBUG_SNAPSCAN=255 no longer produces any output (but i 
tried in csh should i try with export in bash?).

i see other problem with 1.0.16 on the mailing list should i try and revert to 
an even older version?

in the meantime let me try upgrade back to the latest version in the ports 
tree ... doesn't help.

I really have no idea what's wrong with the backends.

On Tuesday March 21 2006 20:25, Oliver Schwartz wrote:
> Hi,
> it seems that the inquiry command fails. Another user reported a
> similar problem on FreeBSD a few days ago. I'm still not sure why the
> problem only seems to affect FreeBSD users, but it seems it can be
> solved by limiting the amount of data data the backend requests in
> the inquiry command.
> You could either try to downgrade to sane-backends 1.0.16 (which
> shouldn't be affected by the bug) or use the latest CVS snapshot (you
> can get the sources from http://www.sane-project.org/snapshots). The
> latter option requires you to build the sane package from source.
> Let me know if this fixes the problem.
> /Oliver

More information about the sane-devel mailing list