[sane-devel] Re: A problem with permissions

Tamkang power_station_2001 at yahoo.com
Tue Mar 28 12:48:33 UTC 2006

 It seems that I have a simillar problem with this one, it looks like the OS doesn't want to gave the USB_CLAIM_INTERFACE, so it appear I/O error. does anyone  have any suggestion ? 
  I use REDHAT 9 kernel 2.4.20-8 and sane-backend 1.0.15 and xsane.0.97 

Thanks for your help

Best regards,

> I've been configuring things on my machine running Debian and have been  > doing well with the exception of one nagging problem: getting SANE to  > run on my user account. When I log into root, it works perfectly, but,  > when I'm logged in as a user, it crashes without any identifiable error.  > The user is in the saned and scanner groups. I have tried to check  > every file and directory to find the one that does not have permission  > set for the user, but I seem to be missing something. Could someone  > suggest somewhere that I might not have thought to look?    You need either udev or hotplug installed, assuming your scanner is  USB and its IDs are known by the version of SANE you're using.    If it still doesn't work, please provide more information: scanner,  libsane version would be a good start.

Blab-away for as little as 1¢/min. Make  PC-to-Phone Calls using Yahoo! Messenger with Voice.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20060328/a5cd5d94/attachment.htm

More information about the sane-devel mailing list