[sane-devel] CanoScan N670U jamming with Ubuntu Dapper.

eugenia eugenia at qld.chariot.net.au
Mon Oct 23 00:08:04 UTC 2006

The Scanner worked perfectly when the Operating systen was Ubuntu 5.10.
The problem started once Ubuntu was upgraded to 6.06 using Synaptic
Package Manager. It was not a 'clean'install.

I have tried Ubuntu forums without success.

I have removed and reinstalled the packages

The scanner still works with Windows (it is a dual boot PC) and the
supplied Canon drivers so it is doubtful that the problem is with the
scanner or the connections to the computer.

The greatest concern now with repeated efforts to solve the problem is
whether the repeated jamming is damaging the scanner

### Using the checklist in Help > Problems I get to

ray at wannabee:~$ cd /
ray at wannabee:/$ sudo gdb xscanimage
GNU gdb 6.4-debian
Copyright 2005 Free Software Foundation, Inc.
GDB is free software, etc...

(gdb) r
Starting program: /usr/bin/xscanimage
(no debugging symbols found)
### Continues until

[Thread debugging using libthread_db enabled]
[New Thread -1218935104 (LWP 7432)]
(no debugging symbols found)
### Continues until

### At this point the 'Preview' or 'Scan' screen comes up. The moment
'Preview' was selected the scanner jammed. The next line appears when
the USB is disconnected to (hopefully) avoid damage to the scanner.

Program received signal SIGPIPE, Broken pipe.
[Switching to Thread -1218935104 (LWP 7432)]
0xffffe410 in __kernel_vsyscall ()
(gdb) r
The program being debugged has been started already.
Start it from the beginning? (y or n) n
Program not restarted.

(gdb) backtrace
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb77425c3 in write () from /lib/tls/i686/cmov/libc.so.6
#2  0xb790047b in XWriteBitmapFile () from /usr/lib/libX11.so.6
#3  0xb79006f4 in _X11TransWrite () from /usr/lib/libX11.so.6
#4  0xb790506b in _XError () from /usr/lib/libX11.so.6
#5  0xb790631e in _XEventsQueued () from /usr/lib/libX11.so.6
#6  0xb78f2b58 in XPending () from /usr/lib/libX11.so.6
#7  0xb7b2038d in _gdk_x11_convert_to_format ()
   from /usr/lib/libgdk-x11-2.0.so.0
#8  0xb7b22d1e in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#9  0xb7829fab in g_main_context_prepare ()
from /usr/lib/libglib-2.0.so.0
#10 0xb782a5ee in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#11 0xb782acb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#12 0xb7c7e765 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x0805015c in ?? ()
#14 0x00000004 in ?? ()
#15 0x0805a934 in _IO_stdin_used ()
#16 0xbf88987c in ?? ()
#17 0x0805a0ac in _IO_stdin_used ()
#18 0x00000000 in ?? ()

### This is another time and when it jammed I again pulled out the USB
connection to stop

Program received signal SIGINT, Interrupt.
[Switching to Thread -1218783552 (LWP 7772)]
0xffffe410 in __kernel_vsyscall ()

(gdb) backtrace
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb776c88d in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xb784f7e8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0xb784fcb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0xb7ca3765 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5  0x0805015c in ?? ()
#6  0x00000004 in ?? ()
#7  0x0805a934 in _IO_stdin_used ()
#8  0xbf9b15fc in ?? ()
#9  0x0805a0ac in _IO_stdin_used ()
#10 0x00000000 in ?? ()

Where do I go from here?

More information about the sane-devel mailing list