[sane-devel] CanoScan N670U/LiDE 20 jamming with FC5

pahre pahre at comcast.net
Mon Sep 11 15:37:32 UTC 2006

I've seen some posts before about problems with this scanner under FC5 (which
appear not always to occur with other distributions).
But the previous posts didn't seem to have a clear solution.
Can somebody please help me out and/or direct me to where a solution is

Canon CanoScan N670U (I believe it is LiDE 20)

Fedora Core 5:	fresh install of /root (not upgrade from previous FC).

Tried with default xsane, scanimage, and then upgraded various packages
related to it.  Same problem throughout:

Jamming of scanner (intermittent, but more often than not)
Both color and gray
Only way out is to unplug USB cable, kill xsane, then plug USB cable and
     restart xsane
Problem occurs sometimes on opening xsane, other times it can be stopped
     by immediately starting a scan.  Also intermittently occurs in the
     middle of scanning a series of pages -- but always at the very
     beginning of a particular scan.  Mechanically:  the pulley in the
     scanner under the window looks to be shaking back and forth a little.
     Nasty noise...  but no smoke (yet).

Kernel has been upgraded:
# uname -a
  Linux essiama 2.6.17-1.2174_FC5 #1 Tue Aug 8 15:30:55 EDT 2006 i686 i686
i386 GNU/Linux
but problem with both kernels.

RPMs after upgrading:

# rpm -qa | grep sane

I.e., xsane up to 0.991-1 and sane-backends up to 1.0.17.  (No rpm for
FC5 for sane-backends 1.0.18 seems to exist yet in the usual repositories.)

Upon hotplugging the USB scanner:

Sep 11 10:22:59 localhost kernel: usb 2-1: new full speed USB device using
uhci_hcd and address 8
Sep 11 10:22:59 localhost kernel: usb 2-1: configuration #1 chosen from 1

Upon starting up xsane and getting an immediate jam:

Sep 11 10:23:22 localhost python: hpssd [WARN] Inrecognized URI:
Sep 11 10:23:22 localhost hpiod: ParDevice::nibble_read failed: Input/output

Note the odd lp0 line that comes up -- I do have a printer running at
/dev/usb/lp0 (and fully working).

Note that lampswitch (on and off) seems to work just fine, turning the color
scanning lights on and off (when not jammed).

The scanner works just fine -- I was fully successful with using it under
FC2 with minimal updating of xsane (0.91 or so, if I remember correctly).
I could verify this with MS Windows, but it sounds like other people have
had the same jamming problem with CanoScan under FC5 and reported that their
scanners are fine under MS Windows.  (Yes, I have verified that the travel
lock is not engaged on the scanner.)

Notice that the sane-backends that show up in the documentation page:


does not have a link for sane-canon (unclear if that means that the scanning
mode is working or just
not documented).

Roughly the same problem with KDE kooka:

# kooka --version
Qt: 3.3.5
KDE: 3.5.1-2.3 Red Hat
Kooka: 0.44

which presumably shares the same backend.  Note that on kooka startup, it
has a splash screen
(to select scanner) which seems to have fully recognized my scanner as
CanoScan N670U LiDE 20:

    Select Scan Device:
    1. plustek:libusb:002:012
       Canon N670U/N676U/LiDE20

Notice that the /var/log/messages error:

Sep 11 10:23:22 localhost hpiod: ParDevice::nibble_read failed: Input/output

shows up regardless of kooka or xsane -- but also shows up if starting up
kooka and the scanner
is not yet plugged into the USB!

Tried running xsane as root (despite the warnings) -- same problem.

# rpm -qa | grep libusb
Found comment to make sure libusb 0.1.12, so ran yum to update, but no
packages found.
Not sure how important this is -- the scanner appears to be recognized.

cat /etc/udev/rules.d/60-libsane.rules
SUBSYSTEM!="usb_device", ACTION!="add", GOTO="libsane_rules_end"
# Canon Inc.|CanoScan N670U/N676U/LIDE 20
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="220d", SYMLINK+="scanner-%k"

View this message in context: http://www.nabble.com/CanoScan-N670U-LiDE-20-jamming-with-FC5-tf2253141.html#a6249202
Sent from the SANE - Dev forum at Nabble.com.

More information about the sane-devel mailing list