[sane-devel] MFP - Samsung SCX-4521F

Heiko Freundel vmuetze at gmx.net
Fri Mar 2 19:10:46 CET 2007

> > for the above mentioned MultiFunktionPrinter Samsung provides an
> > Linux
> > driver which should work with sane. This was a main reason for
> > deciding
> > for that MFP. I tried to use it with Ubuntu 10.0, but without
> > success.
> >
> > Samsung just wrote me, that the driver was not testet with Ubuntu
> > :-(
> >
> >  At http://www.sane-project.org I just found the information, that
> > there
> > is an untested version of the driver.
> >
> > 1. How can Samsung have an driver and the sane-project has not?
> > 2. How can I get the untestet driver from the sane-project?

> Hi Heiko.
> I've just installed a HP F380 MFP in my wife's pharmacy, and I used
> the HP driver. It has to be downloaded from the hplip project site at
> sourceforge. It installs itself in such a way that Sane automatically
> detects it (without changing anything in sane), and also, it's
> recognized
> by CUPS. I suspect a similar procedure is valid for Samsung. On their
> website is a unified driver for Linux.

It should work like this and the printer does.

Ubuntu already installed Sane 1.0.14-1.

I tried different things I found, like:
with no success.

Trying to start xsane from shell shows the following message:
insmod: can't read
No such file or directory
Segmentation fault (core dumped)

When I start the Samsung Unified Driver Configurator (which installs
itself) and then click the scanner button, it closes, with the messages

~$ /opt/Samsung/mfp/bin/Configurator
insmod: can't read
No such file or directory
*** glibc detected *** /opt/Samsung/mfp/bin/Configurator: double free or
corruption (!prev): 0x081c1258 ***
======= Backtrace: =========

But I don't know, whether I need mfpport.ko or where I get it from.

Samsung told me, the driver was not testet with Ubuntu.


More information about the sane-devel mailing list