[sane-devel] UMAX stopped working

Thomas H. George tom at tomgeorge.info
Sun Mar 18 15:37:55 CET 2007

On Sat, Mar 17, 2007 at 11:33:30AM -0400, john at johnallsopp.co.uk wrote:
> Hi
> I've tried the FAQ and all the Sane instructions I can find and can't
> fix this, I'm wondering if anyone can give me a clue.
> I've a UMAX Astra 2200 usb scanner on Fedora 6. It was working, now
> when I use xsane (0.991) I get the interface, and when I click scan I
> get "Failed to start scanner: error during device I/O". My favourite
> bets are:
> 1) I hit a button in the xsane interface that changed something I
> don't know about.
> 2) Something's been updated by the auto update process and messed
> things up
> 3) My scanner is broken and I need a new one.

Don't rush to buy a new scanner like I did.  As I noted in my response
to the posting re Epson V100 about a month ago my Epson Perfection 2400
suddenly began freezing in mid-scan.  After contacting the backend
maintainer and the maintainer of udev I decided the scanner was dying.
I bought an Epson V100 and found it would not work with xsane but Epson
supplied iscan.  So a different scanner and different software but again
the scanner would scan a few pages and then lockup in mid-scan.  Finally
I connected the old Epson Perfection 2400 to a Windows XP box and it
still worked perfectly scan after scan.

Tom George
> I don't think it's permissions, I get roughly the same stuff in root.
> It's dodgy, though. I can sometimes get it to scan a little but I only
> get the first, say, inch of the image.
> I suppose it could be the cable.
> Scanimage -L gives me:
> device `umax:libusb:002:019' is a UMAX     Astra 2200       flatbed
> scanner
> but when I look in, I can't remember now, but would that imply there's
> a /proc/something/002/019 file I need to set permissions on? Well
> there isn't a file.
> Is it time to buy a new scanner or is there something I need to check
> first?
> Cheers
> J
> -- 
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>              to sane-devel-request at lists.alioth.debian.org

More information about the sane-devel mailing list