[sane-devel] Canon FB630u Scanner

Johannes Meixner jsmeix at suse.de
Wed May 2 07:31:03 UTC 2007


On May 1 06:56 Hugh McMaster wrote (shortened):
> On 30/04/07, Dr. Ralf Wepler wrote:
> > I just tried to run the test-programm and "xsane" as root user. Both
> > worked. Running the same as user xx fails. Is it a problem of rights?
> > And, if so, in which files?
> This is a result of user rights not being allowed.  I am not sure how
> to change these for OpenSuse though.

The YaST scanner setup sets scanner access permissions by calling
which checks if the scanner is already listed in
and if not it writes
to set up HAL to trigger resmgr to grant access for normal users.
For openSUSE 10.2 see the details at

For openSUSE 10.2 you may have to enter it manually in
and reboot your computer according to
to apply the changes to HAL.

Kind Regards
Johannes Meixner
SUSE LINUX Products GmbH, Maxfeldstrasse 5, 90409 Nuernberg, Germany
AG Nuernberg, HRB 16746, GF: Markus Rex

More information about the sane-devel mailing list